Signature Issue
Incident Report for ZenCharts
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 07, 2019 - 13:21 EDT
Investigating
There have been reports of users experiencing a white screen after signing documents. The issue is not affecting the actual signature. We are investigating the issue and will have it resolved as soon as possible,
Posted 4 months ago. Jun 07, 2019 - 11:45 EDT
This incident affected: ZenCharts Core Functionality (Charting).