Slower than normal login time
Incident Report for ZenCharts
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 01, 2019 - 06:19 EDT
Investigating
We are aware of some issues logging into your server and our CTO is actively working on a resolution for the issue.

Thank You
Posted 3 months ago. Jul 31, 2019 - 19:52 EDT
This incident affected: ZenCharts Core Functionality (Charting).